strange,洛阳纸贵,保时捷卡宴

频道:趣闻中心 日期: 浏览:271

十三、交换路由综合实验一

组网需求:

1、利用三层交换机实现不同VLAN间通信

2、实现三层交换机和路由器互联互通

3、设置三层交换机DHCP功能

4、路由器上做NAT实现主机上网

5、发布服务器映射,实现外网访问服务器

6、可以远程telnet到设备上

7、三层交换机配置dhcp需在VLAN下选择select dhcp global

操作步骤

路由器的配置

#

aaa

local-user huawei privilege level 3

local-user huawei service-type telnet

local-user huawei password cipher

local-user huawei privilege level 3

local-user huawei service-type telnet

#

user-interface vty 0 4

authentication-mode aaa

#

acl number 2000

rule 5 permit source 192.168.1.0 0.0.0.255

rule 10 permit source 192.168.2.0 0.0.0.255

rule 10 permit source 192.168.3.0 0.0.0.255

rule 15 deny

#

interface GigabitEthernet0/0/0

ip address 10.10.10.1 255.255.255.252

#

interface GigabitEthernet0/0/1

ip address 172.168.1.1 255.255.255.252

nat server protocol tcp global 1.1.1.3 www inside 192.168.3.2 www

nat outbound 2000

#

ip route-static 0.0.0.0 0.0.0.0 1.1.1.2

核心交换机的配置

undo info-center enable

#

vlan batch 2 to 4 100

#

#

dhcp enable

#

ip pool 1

gateway-list 192.168.1.1

network 192.168.1.0 mask 255.255.255.0

dns-list 8.8.8.8

#

ip pool 2

gateway-list 192.168.2.1

network 192.168.2.0 mask 255.255.255.0

excluded-ip-address 192.168.2.10

dns-list 8.8.8.8

#

Aaa

local-user admin password simple huawei

local-user admin privilege level 15

local-user admin service-type telnet

#

interface 铝导辊GigabitEthernet0/0/1

port酱汁淮山 link-type access

port default vlan 100

#

interface GigabitEthernet0/0/2

port link-type trunk

port trunk allow-pass vlan 2 to 4094

#

interface GigabitEthernet0/0/3

port link-type access

port default vlan 4

#

ip route-static 0.0.0.0 0.0.0.0 10.10.10.2

#

user-interface vty 0 4

authentication-mode aaa

接入交换机配置:

#

undo info-center enable

#

Aaa

local-user admin password simple huawei

local-user admin privilege level 15

local-user admin service-type telnet

#

#

vlan batch 2 to 4

#

interface GigabitEthernet0/0/1

port link-type trunk

port trunk allow-pass vlan 2 to 4094

#

interface GigabitEthernet0/0/2

port link-type access

port default vlan 3

#

interface GigabitEthernet0/0/3

port link-type access

port default vlan 2

#

user-interface vty 0 4

authentication-mode aaa

十四、配置BGP路由协议基本功能

组网需求

某个地区拥有多个AS,AS之间有相互访问的需求,因此需要AS之间相互交换本AS内部的路由。由于AS内路由器数量众多,导致路由数量较大,路由变化频繁,如何高效率的在AS之间传递大量路由,并且不占用大量带宽成为一个难题。为解决上述问题,可以使用BGP协议。

路由器各接口及主机的IP地址和掩码如图1所示。RouterC处于AS200,RouterA和RouterB处于AS100。在这几个路由器上部署BGP协议之后,路由器之间可以相互传递路由,并且当任何一个路由器有路由更新时,只需发送路由更新信息给邻居路由器,而无须发送整个路由表,大大节约了网络带宽。

图1配置BGP路由协议基本功能组网图

操作步骤

R1

interface GigabitEthernet0/0/0

ip address 10.1.2.1 255.255.255.0

#

interface GigabitEthernet0/0/1

#

interface NULL0

#

bgp 100

router-id 1.1.1.1

peer 10.1.2.2 as-number 100

#

ipv4-family unicast

undo synchronization

network 10.1.2.0 255.255.255.0

peer 10.1.2.2 enable

#

ipv6-family unicast

undo synchronization

#

R2

interface GigabitEthernet0/0/0

ip address 10.1.2.2 255.255.255.0

#

interface GigabitEthernet0/0/1

ip address 10.1.3.1 255.255.255.0

#

interface NULL0

#

bgp 100

router-id 2.2.2.2

peer 10.1.2.1 as-number 100

peer 10.1.3.2 as-number 200

#

ipv4-family unicast

undo synchronization

i彩田友也香mport-route direct

peer 10.1.2.1 enable

peer 10.1.3.2 enable

#

R3

interface GigabitEthernet0/0/1

ip address 10.1.3.2 255.255.255.0

#

interface NULL0

#

bgp 200

router-id 3.3.3.3

peer 10.1.3.1 as-number 100

#

ipv4-family unicast

undo synchronization

peer 10.1.3.1 enable

#

ipv6-family unicast

undo synchronization

#

检查配置结果

配置注意事项

使用Ping命令验证连通性(注意R2中直连路由引入import-route direct)

十五、配置组播IGMP功能

组网需求

RouterA的GE0/0/1连接组播源,GE0/0/0连接RouterB。RouterB的GE0/0/1连接RouterA,GE0/0/0连接用户侧主机HostA。要求在该网络中部署组播功能,使HostA能够接收视频点播信息。

图1IGMP功能组网图

操作步骤

RouterA的配置

#

multicast routing-enable //全局启动组播协议

#

interface GigabitEthernet0/0/0

ip address 10.0.4.1 255.255.255.0 //连接RouterB的接口地址

pim dm //使能PIM-DM

#

interface GigabitEthernet0/0/1

ip address 10.0.5.1 255.255.255.0 //连接组播源的接口的IP地址

pim dm //使能PIM-DM

#

ip route-static 10.0.3.0 255.255.255.0 10.0.4.2 //配置到达接收者网段的路由

#

RouterB的武川アイ配置

#

multicast routing-enable //全局启动组播协议

#

interface GigabitEthernet0/0/0

ip address 10.0.3.1 255.255.255.0 //连接HostA的接口的IP地址

igmp enable //连接HostA的接口使能igmp

#

interface GigabitEthernet0/0/1

ip address 10.0.4.2 255.255.255.0 //连接RouterA的接口的IP地址

pim dm //使能PIM-DM

#

ip route-static 10.0.5.0 255.255.255.0 10.0.4.1 //配置到达组播源路由,用于组播RPF检查

#

检查配置结果

在RouterB上执行display igmp interface命令可以查看各路由器接口上IGM初中女生的胸部P的配置和运行情况。其中“IGMP state”为up,HostA能够接收视频点播信息。

配置注意事项

全局使能组播功能。

组播源与接收者之神兽托儿所间路由可达,接口上全部使能PIM-DM,保证RPF检查正确。

连接receiver的接口使能IGMP协议

十六、配置住备份VRRP功能

组网需求

如图1所示,主机HostA通过缺省网关访问主机HostB。RouterA和RouterB组成VRRP备份组,作为HostA的缺省网关。

RouterA为主设备,正常情况下,RouterA承担网关工作;当RouterA出现故障时,RouterB承担网关工作。

RouterA恢复后,能在20秒内抢占成为Master。

图1主备备份VRRP组网图

操作步骤

RouterA的配置

#

interface Ethernet1/0/0

ip add4000002288ress 10.1.1.1 255.255.255.0 //连接HostA的接口的IP地址

vrrp vrid 1 virtual-ip 10.1.1潘湘湘.111 //配置虚拟网关地址

vrrp vrid 1 priority 120 //配置RouterA在备份组中的优先级为120

vrrp vrid 1 preempt-mode timer delay 20 //配置抢占方式下的延迟时间

#

interface Ethernet1/0/1

ip address 11.1.1.1 255.255.255.0 //连接HostB的接口的IP地址

#

RouterB的配置

#

interface Ethernet1/0/0

ip address 10.1.1.2 255.255.255.0 //连接HostA的接口的IP地址

vrrp vrid 1 virtual-ip 10.1.1.111 //配置虚拟网关地址

#

interface Ethernet1/0/1

ip address 11.1.1.2 255.255.255.0 //连接HostB的接口的IP地址马才旋

#

检查配置结果

在RouterA上执行display vrrp命令可以查看RouterA上接口Ethernet1/0/0在VRRP备份组中的状态。其中“state”为Master。

在RouterB上执行display vrrp命令可以查看RouterB上接口Ethernet1/0/0在VRRP备份组中的状态。其中“state”为Backup。

配置注意事项

RouterA和RouterB的虚拟网关地址要配置成一致。

需要配置RouterA和RouterB在备份组中的优先级,以确定主从关系。缺省情况下,优先级为100。

确保HostB与RouterA之间、HostB与RouterB之间分别路由可达。

十七、配置负载分担VRRP功能

组网需求

如图1所示,作为RouterA和RouterB的AR路由器加入两个VRRP备份组以实现备份组中各设备既斯克提斯之眼能相互备份,又能分担网络流量。

RouterA作为备份组1的Master,兼任备份组2的Backup。

RouterB作为备份组2的Master,兼任备份组1的Backup。

HostA使用备份组1作网关,HostC主机使用备份组2作为网关。

图1负载分担VRRP组网图

操作步骤

RouterA的配置

#

interface Ethernet1/0/0

ip address 192.168.1.1 255.255.255.0

#

interface Ethernet2/0/0

ip address 10.1.1.1 255.255.255.0 //连接HostA的接口的IP地址

vrrp vrid 1 virtual-ip 10.1.1.111 //配置备份组1的虚拟网关地址

vrrp vrid 1 priority 120 //配置RouterA在备份组1中的优先级为120

vrrp vrid 2 virtual-ip 10.1.1.112 //配置备份组2的虚拟网关地址

#

ospf 1

area 0.0.0.0

network 192.168.1.0 0.0.0.255

network 10.1.1.0 0.0.0.255

#

RouterB的配置

#

interface Ethernet1/0/0

ip ad羊床漏粪板dress 192.168.2.1 255.255.255.0

#

interface Ethernet2/0/0

ip address 10.1.1.2 255.255.255.0 //连接HostC的接口的IP地址

vrrp vrid 1 virtual-ip 10.1.1.111 //配置备份组1的虚拟网关地址

vrrp vrid 2 virtual-ip 10.1.1.112 //配置备份组2的虚拟网关地址

vrrp vrid 2 priority 120 //配置RouterB在备份组2中的优先级为120

#

ospf 1

area 0.0.0.0

network 192.168.2.0 0.0.0.255

network 10.1.1.0 0.0.0.255

#

RouterC的配置

#

interface Ethernet1/0/0

ip address 192.168.1.2 255.255.255.0

#

interface Ethernet2/0/0

ip address 192.168.2.2 255.255.255.0

#

interface Ethernet3/0/0

ip address 20.1.1.1 255.255.255.0

#

ospf 1

area 0.0.0.0

network 192.168.1.0 0.0.0.255

network 192.168.2.0 0.0.0.255

network 20.1.1.0 0.0.0.255

#

检查配置结果

在HostA上对HostB进行tracert测试,可以看到HostA经过RouterA和RouterC到达HostB。显示信息看如下:

tracert 20.1.1.100

traceroute to 20.1.1.100(20.1.1.100), max hops: 30, packet length: 40

1 10.1.1.1 120ms 50 ms 60 ms

2 192.168.1.2 100 ms 60 ms 60 ms

3 20.1.1.100 肖柯130 ms 90 ms 90 ms

在HostC上对HostB进行tracert测试,可以看到HostC经过RouterB和RouterC到达HostB。显示信息看如下:

tracert 20.1.1.100

traceroute to 20.1.1.100(20.1.妖娆乱旧版1.100), max hops: 30, packet length: 40

1 10.1.1.2 30 ms 60 ms 40 ms

2 192.168.2.2 90 ms 60 ms 60 ms

3 20.1.1.100 70 ms 60 ms 90 ms

在RouterA上执行display vrrp命令,可以看到RouterA分别作为备份组1的Master和备份组2的Backup。其中备份组1的“state”为Master,备份组2的“state”为Backup。

display vrrp

Ethernet2/0/0 | Virtual Router 1

state : Master

Virtual IP : 10.1.1.111

Master IP : 10.1.1.1

PriorityRun : 120

PriorityConfig : 120

MasterPriority : 120

Preempt : YES Delay Time : 0

TimerRun : 1 s

TimerConfig : 1 s

Auth Type : NONE

Virtual Mac : 0000-5e00-0101

Check TTL : YES

Config type : normal-vrrp

Create time : 2007-11-22 16:02:21

Last change time : 2007-11-22 16:02:25

Ethernet2/0/0 | Virtual Router 2

state : Backup

Virtual IP : 10.1.1.112

Master IP : 10.1.1.2男人帮米琪

Priorit挤人奶yRun : 100

PriorityConfig : 100

MasterPriority : 100

Preempt : YES Delay Time : 0

TimerRun : 1 s

Auth Type : NONE

Virtual Mac : 0000-5e00-0102

Check TTL : YES

Config type : normal-vrrp

Create time : 2007-11-2浙江日昌升集团官网2 16:03:05

Last change time : 2007-11-22 16:03:09

在RouterB的Ethernet2/0/0接口上执行shutdown命令,模拟备份组2的网关故障。在RouterA上执行display vrrp命令,可以看到RouterA分别作为备份组1的Master和备份组2的Master。其中,备份组1和备份组2的“state”均为Master。此时,两个VRRP备份组的虚拟网关都在RouterA上。

display vrrp

Ethernet2/0/0 | Virtual Router 1

state : Master

Virtual IP : 10.1.1.111

Master IP : 10.1.1.1

PriorityRun : 120

PriorityConfig : 120

MasterPriority : 120

Preempt : YES Delay Time : 0

TimerRun : 1 s

TimerConfig : 1 s

Auth Type : NONE

Virtual Mac : 0000-5e00-0101

Check TTL : YES

Config type : normal-vrrp

Create time : 2007-11-22 16:02:21

Last change time : 2007-11-22 16:02:25

Ethernet2/0/0 | Virtual Router 2

state : Master

Virtual IP : 10.1.1.112

Master IP : 10.1.1.1

PriorityRun : 100

PriorityConfig : 100

MasterPriority : 100

Preempt : YES Delay Time : 0

TimerRun : 1 s

Auth Type : NONE

Virtual Mac : 0000-5e00-0102

Check TTL : YES

Config type : normal-vrrp

Create time : 2007-11-22 16:03:05

Last change time : 2007-11-22 16:03:09

配置注意事项

RouterA和RouterB的在同一个备份组中的虚拟网关地址要配置成一致。

需要配置路由器在不同备份组中的优先级,以确定主从关系。缺省情况下,优先级为100。

十八、以太网链路聚合配置

组网需求

如图3-1所示,SwitchA和SwitchB通过以太链路分别都连接VLAN10和VLAN20,且

SwitchA和SwitchB之间有较大的数据流量。

用户希望SwitchA和SwitchB之间能够提供较大的链路带宽来使相同VLAN间互相通信。

同时用户也希望能够提供一定的冗余度,保证数据传输和链路的可靠性。

图 3-1 配置手工负载分担模式链路聚合组网图

配置思路

采用如下的思路配置负载分担链路聚合:

1. 创建Eth-Trunk接口并加入成员接口,实现增加链路带宽。

说明

接口缺省都加入了VLAN1,因此加入Eth-Trunk前建议先将接口从VLA且望骄阳N1中退出或将接口

Shutdown,避免出现广播风暴。

2. 创建VLAN并将端口加入VLAN。

3. 配置负载分担方式,实现流量在Eth-Trunk各成员接口间的负载分担,增加可靠性。

操作步骤

步骤1 在SwitchA创建Eth-Trunk接口并加入成员接口。SwitchB配置与SwitchA类似,不再赘述。

system-view

[HUAWEI] sysname SwitchA

[SwitchA] interface Eth-Trunk1

S5700&S6700 系列以太网交换机

典型配置举例 3 以太网

78

[SwitchA-Eth-Trunk1] trunkport gigabitethernet 0/0/1 to 0/0/3

[SwitchA-Eth-Trunk1] quit

步骤2 创建VLAN并将端口加入VLAN。SwitchB配置与SwitchA类似,不再赘述。

# 创建VLAN10和VLAN20并分别加入接口。

[SwitchA] vlan batch 10 20

[SwitchA] interface gigabitethernet 0/0/4

[SwitchA-GigabitEthernet0/0/4] port link-type trunk

[SwitchA-GigabitEthernet0/0/4] port trunk allow-pass vlan 10

[SwitchA-GigabitEthernet0/0/4] quit

[SwitchA] interface gigabitethernet 0/0/5

[SwitchA-GigabitE王京岐thernet0/0/5] port link-type trunk

[SwitchA-GigabitEthernet0/0/5] port trunk allow-pass vlan 20

[SwitchA-GigabitEthernet0/0/5] quit

# 配置Eth-Trunk1接口允许VLAN10和VLAN20通过。

[SwitchA] interface Eth-Trunk1

[SwitchA-Eth-Trunk1] port link-type trunk

[SwitchA-Eth-Trunk1] port trunk allow-pass vlan 10 20

步骤3 配置E沙丁鱼挂机th-Trunk1的负载分担方式。SwitchB配置与SwitchA类似,不再赘述。

[SwitchA-Eth-Trunk1] load-balance src-dst-mac

[SwitchA-Eth-Trunk1] quit

步骤4 验证配置结果

在任意视图下执行display eth-trunk 1命令,检查Eth-Trunk是否创建成功,及成员接口

是否正确加入。

[SwitchA] display eth-trunk 1

Eth-Trunk1's state information is:

WorkingMode: NORMALHash arithmetic: According to SA-XOR-DA

Least Active-linknumber: 1 Max Bandwidth-affected-linknumber: 8

Operate status: up Number Of Up Port In Trunk: 3

--------------------------------------------------------------------------------PortName Status Weight

GigabitEthernstrange,洛阳纸贵,保时捷卡宴et0/0/1 Up1

GigabitEthernet0/0/2 Up1

GigabitEthernet0/0/3 Up1

从以上信息看出Eth-Trunk 1中包含3个成员接口GigabitEthernet0/0/1、GigabitEthernet0/0/2

和GigabitEthernet0/0/3。成员接口的状态都为Up。

热门
最新
推荐
标签